Game development as an Art

Sato Game Dev

Code Exercises


Bitwise AND


Source: Hacker Rank

Task

Given set S={1,2,3,...,N}. Find two integers, A and B (where A < B), from set S such that the value of A&B is the maximum possible and also less than a given integer, K. In this case, & represents the bitwise AND operator.

Input Format

The first line contains an integer,T, the number of test cases.
Each of the subsequent lines defines a test case as space-separated integers, N and K, respectively.

Constraints

Output Format

For each test case, print the maximum possible value of A&B on a new line.
Sample Input

3
5 2
8 5
2 2

Sample Output

1
4
0
Explanation

N = 5, K = 2 e S= {1,2,3,4,5}
All possible values of A and B are:
1. A = 1, B = 2; A & B = 0
2. A = 1, B = 3; A & B = 1
3. A = 1, B = 4; A & B = 0
4. A = 1, B = 5; A & B = 1
5. A = 2, B = 3; A & B = 2
6. A = 2, B = 4; A & B = 0
7. A = 2, B = 5; A & B = 0
8. A = 3, B = 4; A & B = 0
9. A = 3, B = 5; A & B = 1
10. A = 4, B = 5; A & B = 4
The maximum possible value of A&B that is also < (K = 2) is 1, so we print 1 on a new line.

My solution:
C#:
 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace BitwiseAND
{
    class Program
    {
        static void Main(string[] args)
        {

            int t = Convert.ToInt32(Console.ReadLine());

            for (int tItr = 0; tItr < t; tItr++)
            {
                string[] nk = Console.ReadLine().Split(' ');

                int n = Convert.ToInt32(nk[0]);

                int k = Convert.ToInt32(nk[1]);

                int maxValue = 0;
                //my solution
                for (int aux1 = 1; aux1 < n-1; aux1++)
                {
                    for (int aux2 = aux1+1; aux2 <= n; aux2++)
                    {
                        if (((aux1 & aux2) > maxValue) && ((aux1 & aux2) < k))
                        {
                            maxValue = aux1 & aux2;
                        }
                    }
                }
                Console.WriteLine("Output:"+ maxValue);

            }
            Console.ReadKey();

        }
    }
}